
ETS Common Errors and Solutions 
Version 1.2 

10/07/2015 
 

Page 1 of 17 
This document was created by the FDIC.  Please do not alter its contents. 

ETS:  Common Errors and Solutions 

This document is intended for the IT Administrators at the State Banking Departments. 

 

If you need further assistance with any of these issues and their resolutions, please contact the 
FDIC Examiner Help Desk at 877-334-2999.  

Exception when running ETS for the first time 

When ETS is first installed, the database is built and ETS opened automatically.  If there are other 
processes tying up the building of the database, this step may fail and cause an unhandled exception. 

Resolution: 
a. Close ETS (the process may still run after closing it; go into the task manager and make sure 

that ETS.exe is not running) 
b. Open SQL Server Management Studio and delete database ETS 
c. Reopen ETS 

SQL Server 2008 Express R2/2012 errors: 

1. Cannot open database:  In ETS, this issue is not given a specific dialog as in ETS-ALERT.  Instead, the 
details can be found in “applicationExceptions.log” (see Appendix C) under error codes 700721a0 or 
bfa9582e. 

Resolution:  
a. Check to make sure the user’s name is a valid login and has the correct access to ‘dbcreator’ 

and ‘bulkadmin’ 
b. If the database doesn’t exist:  When installing the prerequisites, need to ensure all setup files 

are run as administrator.  Specifically, make sure the file SSCERuntime-ENU is run as an 
administrator.  Even though all it is doing is copying the two files to a folder, running as 
administrator either copies another hidden file or gives different security credentials to the file. 

c. If issue was only temporary, e.g. user receives this error the first few times but then it all of a 
sudden is no longer an issue:  It may be possible that there was a temporary disruption to the 
Active Directory (AD) groups.  Since SQL uses ETS, which is a nested group, the user may have 
temporarily lost rights to the database.    

d. If SQL Server was recently installed (and the computer was not rebooted), reboot and try again.  
e. If the steps above do not work, delete the database and restart ETS. 
f. If all else fails, uninstall and reinstall SQL Server from scratch, having the Field Office 

Representative (FOR) follow the setup instructions correctly. 

2.   “Execution of user code in the .NET Framework is disabled.  Enable "clr enabled" configuration 
option” (error code 58781e0e):  
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Resolution:  Contact your local system admin.  Have the system admin login to SQL Server 
Management Studio and enable CLR.  To enable CLR, run the following script in SQL Server as a 
SysAdmin:  

 
exec sp_configure 'clr enabled',1; 
go 
reconfigure; 
go  

 
3. “This text file is not properly formatted.  Please select another text file for import.”: 

 

 
Resolution:   

g. There are errors in the bank data text file that has been provided by the bank.  Ensure the data 
is provided in the correct format as requested from the bank.  Ensure there are no special 
characters in the data, specifically outlying areas of the file such as the end of the file or in the 
empty areas to the right of the text/data.  Make sure there are no hyphens (“-“) intermixed 
with the data.   

h. To troubleshoot data further for errors, please contact the ETS Help Desk who can assign the 
data to the development team/RMS for diagnosis.  

 
4. Unable to establish trusted connections between two examiners or unable to “see” examiners 

ETS collaboration intermittently fails which results in two examiners being unable to “see” one 
another.  No error message is thrown, but examiner 1 cannot add examiner 2 to his or her exam or 
establish trusted connections (on the first use of ETS). Often, this can be corrected by having both 
examiners delete Temporary Internet Files in Internet Options of Internet Explorer. If that doesn’t 
help double check to make sure that both examiners are connected to the same Aruba access point.  
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Appendix A:  Importing Using the Manage Portfolio Profile Function 

Using a standard profile as a base (loans) 

1. Go to the Asset Review tab. 
2. Click on “Manage Portfolio Profiles”. 
3. Select a built-in import profile that is applicable to your file and click “Edit”. 
4. Browse for your data file and click “Open”. 
5. The Manage Import Profiles wizard should be populated with the chosen file and the settings 

from the chosen built-in import profile. 
6. Navigate through the wizard and make changes as needed. 
7. Click “Finish”, rename your import profile, and click “Save & Proceed with import”, making sure 

to change the Profile Name.   
8. Proceed to fix any errors and commit your file to portfolio.   

 
Creating a new profile from scratch (all asset types) 
1. Go to the Asset Review tab. 
2. Click on “Manage Portfolio Profiles”. 

 

 
 

3. Select the correct asset type in the Select Asset Type dropdown at the top of the tab. 
4. Select “Create” 
5. Browse to the asset file and select “Open”. 
6. In Step 1 of 3 of the Manage Import Profiles wizard, select Delimited or Fixed Width according to 

the file type (this will set the field widths for Step 2 of 3).  The header is also set here. 
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7. Step 2 of 3 allows for setting of the column breaks.  These are done automatically based on the 

selection in Step 1 and may be manually configured.  

 
8. Column naming is done in Step 3 of 3.  When Import Profiles are Created, column values default 

to “Select Field Name”, whereas if Edit was selected initially the values are populated based on 
the profile being edited. 
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In order to advance from this step, the following requirements must be met: 

• All options under “Required” must be used 
• All columns must be assigned names, or Excluded 

If a column is assigned a date-type name but does not fit a date format, the Date Format 
Discrepancy appears, allowing the user to set the correct format.  
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Appendix B:  Configuration Guide for SQL Server 

SQL Server Configurations:  Logins and Server Roles 

1. Open SQL Server Management Studio: 
a. Go to Start > All Programs > Microsoft SQL Server 2012 > SQL Server Management Studio  
b. Once open, connect to the server 

2. From the panel on the left, expand the “Security” folder and then expand the “Logins” folder.   
a. If Login is not present, user must contact their system administrator to be added into SQL 

Server.   
b. User should see PROD\etsusers if an FDIC employee (ex. PROD\jzastudil) 
c. State users should see [their domain]\[their username] 

 

3. Once Login is confirmed, expand the ‘Server Roles” folder located just below “Security” 
a. There are two folders that users are required to be assigned to, the ‘bulkadmin’ and 

‘dbcreator’.  If user is not in these folders, then they will not be able to access the ETS 
database. 

b. To add user to folder, double click on either folder and a window will pop up.  Select Add 
from the bottom right corner. 
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c. Once you click on “Add…” another window will pop up.  Select “browse…” 
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d. Select your login (PROD\etsuser; in this example it will be PROD\jzastudil) and click “OK”

 
e. Accept all of the changes and repeat this process for the ‘dbcreator’ folder 
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Appendix C:  Accessing Log Files for ETS and ETS-FREDDY 

These log files are a critical piece to being able to troubleshoot and fix issues in a timely manner.  The 
Examiner Help Desk will request these files whenever a new Remedy Ticket is created. 

Accessing ETS log files 

1. Create a file on your Desktop titled “ETS Log Files” 
2. Open ETS 
3. Press Ctrl + Shift + F10 to open ETS folder location 

a. Alternatively, open the task manager, right click on ETS under Processes, and select Open 
File Location 

4. Search for *.log to filter out necessary log files 
5. Copy all log files to the ETS Log Files folder on your desktop. 
6. Zip the folder and send to the Examiner Help Desk. 

a. If the files are too large to send, or get blocked by the FDIC Gateway, you will likely need to 
open an FDICconnect session with the Help Desk for easier delivery. 

**Update 10/05/15 – ETS 1.1 now has a built in shortcut that will create a zip file with all of the log files.  
The shortcut is Ctrl+Shift+F8** Note: Ensure ETS is open and is the active application on your screen. 

 

Accessing FREDDY log files  

1. Open FREDDY 
2. Select the Tools tab on the left 
3. Select “Open ETS-FREDDY Log” 
4. ETS-FREDDY.log should open in Notepad 
5. Select File > Save As… and save to the Desktop or another easily accessible folder. 
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Appendix D:  Purging and Archiving 

ETS is not a system of record and is not intended to retain any production related to exams.  The ETS 
system itself retains operational information in Config DB and ETS Log.   

At the end of an exam, ETS users according to policy should remove the exam information from their 
local ETS databases and laptop manually.  Removal of this information is the responsibility of the ETS 
user.  Removal of an exam from Central Peer will occur in order to protect sensitive information and 
retain exam data only in the systems of record according to the following criteria.  There are two ways in 
ETS to accomplish this: 

1. Auto Purge – Each copy of ETS will automatically check the Mail Date fields in ViSION and 
SOURCE for each of a user’s exams when the application starts.  Any exams for which a Mail 
Date has passed will be automatically deleted from that user’s local ETS database. 

a. The Central Peer also performs the same Mail Date check daily.  Any exams for which 
the Mail Date has passed in ViSION or SOURCE will be deleted from the central peer. 

b. Populating the Mail Date field in ETS will not trigger the auto purge, it is only for 
reference and does not update ViSION or Source.  Mail date can only be set on an exam 
through the ViSION Web Interface or SOURCE direct interface access to which is 
controlled by ViSION and SOURCE security tables. 

c. The auto purge won’t delete anything if the user lacks access to ViSION or SOURCE or 
the exam is offline. 

2. Remove Exam – The ETS user can select Remove Exam from the My Exams screen at any time, 
which will delete the exam from their local ETS database.  Other team members will not be 
affected by someone else removing their exam. 

a. The Central Peer won’t send removed exams back to a user. 
b. The Central Peer will periodically clean up any exams whose team members have all 

removed their exam, and which have been unchanged for the past 120 days.  
i. Note as long as there is one participant on an exam it will stay on central peer.  

Removal of participants from an exam is a manual process. 
 

The available methods for removing exam data depend on the agencies and access to systems of record 
involved at each exam, as shown in the following table: 

Agency Auto Purge Remove Exam Central Peer Uses 

FDIC Only Yes Yes Auto Purge 

Joint FDIC & State Yes Yes Auto Purge 

State Only  (With ViSION Record) Yes –  
Compare to ViSION first 

Yes Auto Purge 

State Only  (No ViSION Record) No Yes Auto Cleanup 
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FRS No Yes N/A 

State /FRS joint exam, State in the lead (No ViSION record) No Yes Auto Cleanup 

FRS/State joint exam, FRS in the lead (No ViSION record) No Yes Auto Cleanup 

 

Other notes about the removal process: 

• Any export files, archives or backups on the user’s local machine will have to be addressed by 
the user per applicable policy.  Neither the auto purge nor the manual removal will affect these 
files. 

• Removing a user from the exam team will not remove the exam from their local machine.  They 
will be read-only for that exam until they remove the exam or wait for the auto purge. 

• A removed exam can be restored if another team member adds the user back onto the exam 
team. 
 

CONSTRAINTS: 

ETS-ALERT functionality continues in ETS today, but various enhancements have been implemented to 
correct many of the known issues.  It should be noted that ETS-ALERT archives and ETS archives are NOT 
the same.  In ETS, the backup function backs up all data that is on the local machine related to the 
selected exam. 

To delete an exam: 

1. Select an exam from the My Exams area in the File tab. 
2. Click Remove to remove the exam and all associated data from the list of Available Exams.  
3. Next, click Recent Institutions from the File tab.  
4. Select the bank for deletion and click Delete.  

Removing an exam from ETS will not remove any of the following: 

• Built-In Queries 

• Custom Queries 

• Built-In Views 

• Custom Views 

• Built-In Reasons Lined Definitions 

• Built-In Risk Factor Definitions 

• Import Profiles 

• Reports  

• Templates 

• User Preferences 

• Institutions 

• List of Users/Examiners 

• Any saved information that the user has 
deemed safe from purge 
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Additionally, the system allows users the ability to create an exam archive for retention purposes.  Upon 
completing the examination process, the user creates an archive of the exam package.  During this 
process, the system identifies all the available elements associated with the exam and then creates a 
manifest listing all elements included in the exam archive.  The manifest is created and included in each 
exam archive regardless of the archive contents.  The content of the manifest is specific to each exam.  

During the save process, the ETS application compresses and encrypts the exam archive and saves the 
file to the selected location.  The user can then save the exam archive to the designated repository.    
 
The purpose of the diagram below is to show the transit of PII information to and from an ETS user’s 
laptop, in and out of ETS control.  On the left is in bound or exported PII information and its source.  All 
of this information is supplied in files from outside ETS or is exported from ETS at examiner request.  
This information is not encrypted except when at rest on the examiners laptop due to whole disk 
encryption.  The ETS primary data store is the SQL Server database, which relies of AD security 
credentials and whole disk encryption for protection.  Backup and Archive files are encrypted and 
archived with zip.  Archive files are intended for the designated repository.  All ETS services 
communications is encrypted and authorized by individual.  ETS is not a system of record and all exam 
information should either be deleted by the examiner explicitly or removed by the mail date exam 
deletion process. 

 

All encrypted data in the above chart is shown in orange 
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Appendix E:  Steps to Uninstall ETS and Delete the Database 

Steps to Uninstall ETS 

1. Open the Control Panel and navigate to Programs and Features 
2. Find ETS from the list.  Highlight and choose to Uninstall. 

 

3. You can elect to completely remove the application, or restore to its previous state*   
*Restoring to the previous state is essentially a rollback feature built into ETS.  This option will only 
be available if the computer had previously “upgraded” from a prior version.  When selecting this 
option, it will roll back ETS back to the prior version (i.e. ETS 1.1  ETS 1.0) 

 

4. Once the process is complete, the dialog box (shown above) will close.  Please go back to the 
Programs and Features list and verify ETS has been uninstalled or rolled back to a prior version. 
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Steps to Delete the ETS Database 

1. Open SQL Server Management Studio: 
i. Click START > All Programs > Microsoft SQL Server 2012 > SQL Server Management Studio.  

ii. Once open, Connect to the Server: 
* Server Name should read:  [ComputerName]\FDIC2008 
* Authentication should read:  Windows Authentication 
* Username should remain greyed out.   
 

 
 

2. Once successfully connected, 5 folders should drop down on the left hand side of the window 
 

 
 

3. Expand (+) the Databases folder and you should see the ETS database - simply titled ETS 
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4. To delete, right click on the ETS database and navigate to Delete (3rd one up from the bottom) 
5. From there a new popup window will appear, you MUST* uncheck the first option (Delete backup 

and restore history information for databases) and check the second option (close existing 
connections), then click OK. 

 
*Deleting the backup and restore history information will delete all of the automatic backups that 
SQL Server creates on a periodic basis; which can be located at:  C:\Program Files\Microsoft SQL 
Server\MSSQL10_50.FDIC2008\MSSQL\Backup 
*Closing the existing connections, will just ensure that the ETS database is not in use under another 
system profile. 
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Appendix F:  ETS Access for External Users 

 

Users’ access to FDIC services is restricted by their agency and the state and class of the institution: 

Access Rights FDIC examiner, 
any bank 

State examiner, 
same state 

State examiner, 
different state 

FRS examiner, 
any bank 

Download Templates, 
Institution Profile 

Yes Yes Yes Yes 

Set up exam + 
Gather Artifacts 

Yes Yes No No 

Upload to IER Yes Yes No No 
Upload to ViSION Yes No No No 
Access to SOURCE Restricted No No No 

 

Timing:  These external access credentials will expire after 24 hours or when ETS is closed.  Secure 
Connection Requests between users last for 1 year. 

Effects:  Without credentials, ETS will not be able to connect to FDIC services, which may limit an 
examiner’s ability to gather key data.  However, offline sharing (via local network, ARUBA’s, or 
Distribution Package files) can still be used.  ETS also needs these credentials to activate a new machine 
(or user). 

 
 

Email, e.g. etsx13@gmail.com 

PIN is for physical “hard” tokens only 
Users of soft tokens are not required 
to enter a PIN 

OTP is generated by the token 

This prompt will appear any time a 
non-FDIC user attempts to connect to 
an FDIC service through ETS.  For 
example, connecting to initiate the 
Gather Artifacts function will cause 
this prompt to appear.  

mailto:etsx13@gmail.com

